Thursday, March 15, 2012

BIT ROUTER ( RIP, OSPF, EIGRP, BGP, MPLS VPN IP ) EOS DIVES

Tanggal 10-11 Maret 2012, berlangsung selama 2 hari pelatihan bit router yang di laksanakan di Menara multimedia lnt 12 ( markas c4 ) dengan pemateri pak adit, membahas tentang pengenalan routingan ( RIP, OSPF, EIGRP, BGP ) serta cara konfigurasi pada setiap router yang ada. Praktek yang di lakukan dengan menggunakan GNS 3 bisa di donlot di sini : www.gns3.net/download/  untuk IOS nya bisa cari sendiri ya :D
Oke langsung ajah deh, di bawah ini adalah topologi sederhana yang di gunakan dalam praktek kali ini,
 
 Gambar Topologi Area

Berikut ini adalah konfigrasinya :

LL ROUTERS:
(config)#
int f0/0
description *** connected to LAN ***
ip address 10.1.x.1 255.255.255.0
bandwidth 100000    (kbps)
speed 100        (mbps)
duplex full
no shutdown

int s0/x
description *** connected to R-... ***
ip address 10.0.0.x 255.255.255.252
bandwidth 2048     (kbps)
no shutdown

router rip
ver 2
passive-int f0/0
net 10.0.0.0
no auto-summary
end

copy run start ATAU write memory

# show ip protocol
# sh ip route
# debug ip rip
# terminal monitor   ==> bagi yg telnet
# no debug all ATAU undebug all


Menghapus konfigurasi router/switch:
> enable
# erase startup-config
# reload

Setelah router selesai booting:
Would you like to enter the initial configuration dialog? [yes/no]:  n --> masuk ke Command Line Interface (CLI)

> enable
# show version
# sh flash
# sh controller s0/x          --> cek DCE/DTE interface

# configure terminal
(config)#  hostname Router-JKT,SBY,MKS,MDN,BPN
(config)#  kom

(config)#  interface f0/x
(config-if)# ip address 10.1.x.y 255.255.255.z  
(config-if)# no shutdown  

(config-if)# interface s0/x
(config-if)# ip address 10.1.x.10 255.255.255.252
(config-if)# clock rate 2000000      --> khusus interface DCE
(config-if)# bandwidth 2048
(config-if)# no shutdown  

(config-line)# line vty 0 4
(config-line)# password telkom
(config-line)# login   
(config-line)# exec-timeout 5 0   --> session timeout 5 menit 0 detik
(config-line)# logging synchronous    --> agar prompt muncul lagi ketika ada                         logging di layar

(config-line)# line console 0
(config-line)# no login --> tidak ngecek password
(config-line)# exec-timeout 0 0    --> unlimited timeout 
(config-line)# logging synchronous
(config-line)# end

# copy run start
# write memory      ATAU       # wr
----------------------------------------------------------

RIP:
# conf t
(config)# router rip
(config-router)# version 2
(config-router)# network 10.0.0.0
(config-router)# no auto-summary        --> jika di discontiguous NW
(config-router)# passive-interface f0/0  --> disable fungsi send-receive                                      routing update di int f0/0
(config-router)# end

# sh ip protocols  --> melihat routing protocol yg sdh di-configure
# sh ip route         --> melihat routing table
# debug ip rip     --> melihat proses send-receive update secara realtime
# terminal monitor --> utk melihat debug bagi yg telnet

# sh debug  --> melihat proses debug yg sedang kita aktifkan

# no debug all  ATAU # undebug all   --> mematikan proses debug

# sh debug

(config)# no router rip

-------------------------------------------------------

C:> route add 10.0.0.0 mask 255.240.0.0 10.1.x.1

ftp://10.1.1.100 --> topology.jpg

=======================================================
OSPF:
JKT: 10.100.100.1/32
SBY: 10.100.100.2/32
DPS: 10.100.100.3/32
MKS: 10.100.100.4/32
MDN: 10.100.100.5/32
PDG: 10.100.100.6/32
BTM: 10.100.100.7/32
BPN: 10.100.100.8/32
SMD: 10.100.100.9/32
BJM: 10.100.100.10/32

JKT:
# conf t
(config)# int loopback 0
(config-if)# description *** as Router-ID for OSPF process ***
(config-if)# ip address 10.100.100.1 255.255.255.255
(config-if)# no shutdown
(config-if)# exit

(config)# router ospf 100
(config-router)# network 10.0.0.1 0.0.0.0 area 0
(config-router)# network 10.0.0.13 0.0.0.0 area 0
(config-router)# network 10.0.0.25 0.0.0.0 area 0
(config-router)# network 10.1.1.1 0.0.0.0 area 0
(config-router)# network 10.100.100.1 0.0.0.0 area 0
(config-router)# passive-interface f0/0
(config-router)# end

SBY:
# conf t
(config)# int loopback 0
(config-if)# description *** as Router-ID for OSPF process ***
(config-if)# ip address 10.100.100.2 255.255.255.255
(config-if)# no shutdown
(config-if)# exit

(config)# router ospf 100
(config-router)# network 10.0.0.2 0.0.0.0 area 0
(config-router)# network 10.0.0.9 0.0.0.0 area 0
(config-router)# network 10.0.0.5 0.0.0.0 area 0
(config-router)# network 10.1.2.1 0.0.0.0 area 0
(config-router)# network 10.100.100.2 0.0.0.0 area 0
(config-router)# passive-interface f0/0
(config-router)# end

DPS:
# conf t
(config)# int loopback 0
(config-if)# description *** as Router-ID for OSPF process ***
(config-if)# ip address 10.100.100.3 255.255.255.255
(config-if)# no shutdown
(config-if)# exit

(config)# router ospf 100
(config-router)# network 10.0.0.6 0.0.0.0 area 0
(config-router)# network 10.1.3.1 0.0.0.0 area 0
(config-router)# network 10.100.100.3 0.0.0.0 area 0
(config-router)# passive-interface f0/0
(config-router)# end

MKS:
# conf t
(config)# int loopback 0
(config-if)# description *** as Router-ID for OSPF process ***
(config-if)# ip address 10.100.100.4 255.255.255.255
(config-if)# no shutdown
(config-if)# exit

(config)# router ospf 100
(config-router)# network 10.0.0.10 0.0.0.0 area 0
(config-router)# network 10.1.4.1 0.0.0.0 area 0
(config-router)# network 10.100.100.4 0.0.0.0 area 0
(config-router)# passive-interface f0/0
(config-router)# end

MDN:
# conf t
(config)# int loopback 0
(config-if)# description *** as Router-ID for OSPF process ***
(config-if)# ip address 10.100.100.5 255.255.255.255
(config-if)# no shutdown
(config-if)# exit

(config)# router ospf 100
(config-router)# network 10.0.0.14 0.0.0.0 area 0
(config-router)# network 10.0.0.17 0.0.0.0 area 0
(config-router)# network 10.0.0.21 0.0.0.0 area 0
(config-router)# network 10.1.5.1 0.0.0.0 area 0
(config-router)# network 10.100.100.5 0.0.0.0 area 0
(config-router)# passive-interface f0/0
(config-router)# end

PDG:
# conf t
(config)# int loopback 0
(config-if)# description *** as Router-ID for OSPF process ***
(config-if)# ip address 10.100.100.6 255.255.255.255
(config-if)# no shutdown
(config-if)# exit

(config)# router ospf 100
(config-router)# network 10.0.0.22 0.0.0.0 area 0
(config-router)# network 10.1.6.1 0.0.0.0 area 0
(config-router)# network 10.100.100.6 0.0.0.0 area 0
(config-router)# passive-interface f0/0
(config-router)# end

BTM:
# conf t
(config)# int loopback 0
(config-if)# description *** as Router-ID for OSPF process ***
(config-if)# ip address 10.100.100.7 255.255.255.255
(config-if)# no shutdown
(config-if)# exit

(config)# router ospf 100
(config-router)# network 10.0.0.18 0.0.0.0 area 0
(config-router)# network 10.1.7.1 0.0.0.0 area 0
(config-router)# network 10.100.100.7 0.0.0.0 area 0
(config-router)# passive-interface f0/0
(config-router)# end

BPN:
# conf t
(config)# int loopback 0
(config-if)# description *** as Router-ID for OSPF process ***
(config-if)# ip address 10.100.100.8 255.255.255.255
(config-if)# no shutdown
(config-if)# exit

(config)# router ospf 100
(config-router)# network 10.0.0.29 0.0.0.0 area 0
(config-router)# network 10.0.0.26 0.0.0.0 area 0
(config-router)# network 10.0.0.33 0.0.0.0 area 0
(config-router)# network 10.1.8.1 0.0.0.0 area 0
(config-router)# network 10.100.100.8 0.0.0.0 area 0
(config-router)# passive-interface f0/0
(config-router)# end

SMD:
# conf t
(config)# int loopback 0
(config-if)# description *** as Router-ID for OSPF process ***
(config-if)# ip address 10.100.100.9 255.255.255.255
(config-if)# no shutdown
(config-if)# exit

(config)# router ospf 100
(config-router)# network 10.0.0.30 0.0.0.0 area 0
(config-router)# network 10.1.9.1 0.0.0.0 area 0
(config-router)# network 10.100.100.9 0.0.0.0 area 0
(config-router)# passive-interface f0/0
(config-router)# end

BJM:
# conf t
(config)# int loopback 0
(config-if)# description *** as Router-ID for OSPF process ***
(config-if)# ip address 10.100.100.10 255.255.255.255
(config-if)# no shutdown
(config-if)# exit

(config)# router ospf 100
(config-router)# network 10.0.0.34 0.0.0.0 area 0
(config-router)# network 10.1.10.1 0.0.0.0 area 0
(config-router)# network 10.100.100.10 0.0.0.0 area 0
(config-router)# passive-interface f0/0
(config-router)# end

ALL ROUTERS:
# copy run start    ATAU    #write

# sh ip ospf
# sh ip ospf interface
# sh ip ospf neighbor        ==> neighbor table / adjacency database
# sh ip ospf database        ==> topology table / link state database
# sh ip route            ==> routing table / forwarding database
# sh ip protocols

# debug ip ospf event
# debug ip ospf packet
------------------------------------------------------------------


====================================================================
OSPF Multiarea (area 0,1,2,3)
OSPF:
JKT: 10.100.100.1/32
SBY: 10.100.100.2/32
MKS: 10.100.100.3/32
DPS: 10.100.100.4/32
MDN: 10.100.100.5/32
PDG: 10.100.100.6/32
BTM: 10.100.100.7/32
BPN: 10.100.100.8/32
SMD: 10.100.100.9/32
BJM: 10.100.100.10/32


SBY:
(config)# no router ospf 100

(config)# router ospf 500
(config-router)# net 10.100.100.2 0.0.0.0 area 0
(config-router)# net 10.0.0.2 0.0.0.0 area 0
(config-router)# net 10.0.0.5 0.0.0.0 area 1
(config-router)# net 10.0.0.9 0.0.0.0 area 1
(config-router)# net 10.1.2.1 0.0.0.0 area 1
(config-router)# passive-interface f0/0

MDN:
(config)# no router ospf 100

(config)# router ospf 500
(config-router)# net 10.100.100.5 0.0.0.0 area 0
(config-router)# net 10.0.0.14 0.0.0.0 area 0
(config-router)# net 10.0.0.21 0.0.0.0 area 3
(config-router)# net 10.0.0.17 0.0.0.0 area 3
(config-router)# net 10.1.5.1 0.0.0.0 area 3
(config-router)# passive-interface f0/0

# sh ip int brief

BPN:
(config)# no router ospf 100

(config)# router ospf 500
(config-router)# net 10.100.100.8 0.0.0.0 area 0
(config-router)# net 10.0.0.26 0.0.0.0 area 0
(config-router)# net 10.0.0.29 0.0.0.0 area 2
(config-router)# net 10.0.0.33 0.0.0.0 area 2
(config-router)# net 10.1.8.1 0.0.0.0 area 2

SMD:
(config)# no router ospf 100

(config)# router ospf 500
(config-router)# net 10.100.100.9 0.0.0.0 area 2
(config-router)# net 10.0.0.30 0.0.0.0 area 2
(config-router)# net 10.1.9.1 0.0.0.0 area 2

BJM:
(config)# no router ospf 100

(config)# router ospf 500
(config-router)# net 10.100.100.10 0.0.0.0 area 2
(config-router)# net 10.0.0.34 0.0.0.0 area 2
(config-router)# net 10.1.10.1 0.0.0.0 area 2


MKS:
(config)# no router ospf 100

(config)# router ospf 500
(config-router)# net 10.100.100.3 0.0.0.0 area 1
(config-router)# net 10.0.0.10 0.0.0.0 area 1
(config-router)# net 10.1.4.1 0.0.0.0 area 1

DPS:
(config)# no router ospf 100

(config)# router ospf 500
(config-router)# net 10.100.100.4 0.0.0.0 area 1
(config-router)# net 10.0.0.6 0.0.0.0 area 1
(config-router)# net 10.1.3.1 0.0.0.0 area 1

BTM:
(config)# no router ospf 100

(config)# router ospf 500
(config-router)# net 10.100.100.7 0.0.0.0 area 3
(config-router)# net 10.0.0.18 0.0.0.0 area 3
(config-router)# net 10.1.7.1 0.0.0.0 area 3

PDG:
(config)# no router ospf 100

(config)# router ospf 500
(config-router)# net 10.100.100.6 0.0.0.0 area 3
(config-router)# net 10.0.0.22 0.0.0.0 area 3
(config-router)# net 10.1.6.1 0.0.0.0 area 3

---------------------------------------------------------------
OSPF simple authentication

(config)# int s0/x
(config-if)# description *** connected to Router lain ***
(config-if)# ip ospf authentication ==> type 1                     OSPF authentication
(config-if)# ip ospf authentication-key TELKOM
(config-if)# end

# debug ip ospf adj
# sh ip ospf neigh
# sh ip route

JKT:
(config)# int s0/0
(config-if)# description *** connected to Router-MDN ***
(config-if)# ip ospf authentication            ==> type 1 OSPF authentication
(config-if)# ip ospf authentication-key TELKOM

(config-if)# int s0/1
(config-if)# description *** connected to Router-SBY ***
(config-if)# ip ospf authentication            ==> type 1 OSPF authentication
(config-if)# ip ospf authentication-key TELKOM
(config-if)# end

SBY:
(config)# int s0/0
(config-if)# description *** connected to Router-BPN ***
(config-if)# ip ospf authentication            ==> type 1 OSPF authentication
(config-if)# ip ospf authentication-key TELKOM

(config-if)# int s0/1
(config-if)# description *** connected to Router-JKT ***
(config-if)# ip ospf authentication            ==> type 1 OSPF authentication
(config-if)# ip ospf authentication-key TELKOM

(config-if)# int f0/1
(config-if)# description *** connected to Router-MKS ***
(config-if)# ip ospf authentication            ==> type 1 OSPF authentication
(config-if)# ip ospf authentication-key TELKOM
(config-if)# end

BPN:
(config)# int s0/0
(config-if)# description *** connected to Router-SBY ***
(config-if)# ip ospf authentication            ==> type 1 OSPF authentication
(config-if)# ip ospf authentication-key TELKOM
(config-if)# end

MKS:
(config)# int f0/1
(config-if)# description *** connected to Router-SBY ***
(config-if)# ip ospf authentication            ==> type 1 OSPF authentication
(config-if)# ip ospf authentication-key TELKOM
(config-if)# end

# sh ip ospf neighbor
# debug ip ospf adj
# terminal monitor    ==> agar bisa lihat output debug, khusus bagi yg via te

Menghapus OSPF simple authentication:
(config)# int s0/x
(config-if)# no ip ospf authentication
(config-if)# no ip ospf authentication-key
(config-if)# end
-----------------------------------------------
# debug ip ospf adj

OSPF MD5 authentication
(config)# int s0/x
(config-if)# ip ospf authentication message-digest
(config-if)# ip ospf message-digest-key 7 md5 TELKOM
(config-if)# end

menghapus OSPF MD5 authentication:
(config)# int s0/x
(config-if)# no ip ospf authentication message-digest
(config-if)# no ip ospf message-digest-key 7
(config-if)# end

no router rip
no router ospf x

--------------------------------------------------------

remove OSPF:

(config)# no router ospf x
(config)# no router rip
(config)# end

# write
# copy run start

-----------------------------------------------------------------
=============================================================
EIGRP configuration:

(config)# router eigrp 65000  
(config-router)# network 10.0.0.0
(config-router)# passive-interface f0/0
(config-router)# end

# sh ip eigrp neighbor
# sh ip eigrp topology  --> P = passive (jaringannya stabil, tidak up-down)
# sh ip route

# debug ip eigrp
# terminal monitor    


contoh:
BPN:
router eigrp 65000
net 10.1.8.0 0.0.0.255
net 10.0.0.24 0.0.0.3
==================================
EIGRP MD5 authentication:
(config)# key chain KC-JKT
(config-keychain)# key 9
(config-keychain-key)# key-string TELKOM

(config-keychain-key)# int s0/x
(config-if)# description *** interface yg terhubung ke router lain ***
(config-if)# ip authentication mode eigrp 65000 md5
(config-if)# ip authentication key-chain eigrp 65000 KC-JKT
(config-if)# end

# sh key chain
# sh run int ...    --> interface yg dipasangi key-chain
# sh ip eigrp neighbor
# sh ip route
# debug eigrp packet hello

Remove EIGRP authentication:
(config)# no key chain KC-JKT

(config)# int s0/x
(config-if)# no ip authentication mode eigrp 65000 md5
(config-if)# no ip authentication key-chain eigrp 65000 KC-JKT


(config)# no router eigrp 65000

========================================

Basic MPLS configuration:

(config)# ip cef    ==> agar create FIB

(config)# int s0/x
(config-if)# mpls ip
(config-if)# mpls label protocol ldp    (opsi: TDP, both)
(config-if)# end


JKT:
(config)# ip cef

(config)# int s0/0
(config-if)# mpls ip
(config-if)# mpls label protocol ldp

(config)# int s0/1
(config-if)# mpls ip
(config-if)# mpls label protocol ldp
(config-if)# end

SBY:
(config)# ip cef

(config)# int s0/0
(config-if)# mpls ip
(config-if)# mpls label protocol ldp

(config)# int s0/1
(config-if)# mpls ip
(config-if)# mpls label protocol ldp

(config)# int f0/1
(config-if)# mpls ip
(config-if)# mpls label protocol ldp
(config-if)# mpls mtu 1504           --> khusus interface LAN (ethernet)
(config-if)# end

MKS:
(config)# ip cef

(config)# int f0/1
(config-if)# mpls ip
(config-if)# mpls label protocol ldp
(config-if)# mpls mtu override 1504       --> khusus interface LAN (ethernet)
(config-if)# end

BPN:
(config)# ip cef

(config)# int s0/0
(config-if)# mpls ip
(config-if)# mpls label protocol ldp
(config-if)# end


ALL:
# sh mpls ldp discovery  --> melihat neighbor LDP
# sh mpls ldp binding      --> LIB (label information base)
# sh mpls forwarding-table  --> LFIB (label forwarding information base)
# sh ip cef detail        --> FIB (forwarding information base)

Remove MPLS config:
(config)# int ...
(config-if)# description *** interface yg terhubung ke router lain ***
(config-if)# no mpls ip
(config-if)# no mpls label protocol ldp
(config-if)# no mpls mtu 1504   --> khusus interface LAN (ethernet)
(config-if)# end

========================
(config)# no router eigrp 65000

IGP using EIGRP di JKT & MDN:
(config)# router eigrp 65002
(config-router)# net 10.0.0.0
(config-router)# no auto-summary
(config-router)# passive-interface f0/0

BGP JKT:
(config-router)# router bgp 65002
(config-router)# no synchronization
(config-router)# no auto-summary
(config-router)# neighbor 10.100.100.2 remote-as 65002
(config-router)# neighbor 10.100.100.2 update-source loopback 0
(config-router)# neighbor 10.100.100.2 next-hop-self
(config-router)# neighbor 10.0.0.6 remote-as 65001
(config-router)# network 10.0.0.0 mask 255.255.255.252
(config-router)# network 10.1.2.0 mask 255.255.255.0
(config-router)# network 10.100.100.1 mask 255.255.255.255

BGP MDN:
(config-router)# router bgp 65002
(config-router)# no synchronization
(config-router)# no auto-summary
(config-router)# neighbor 10.100.100.1 remote-as 65002
(config-router)# neighbor 10.100.100.1 update-source loopback 0
(config-router)# neighbor 10.100.100.1 next-hop-self
(config-router)# network 10.0.0.0 mask 255.255.255.252
(config-router)# network 10.1.1.0 mask 255.255.255.0
(config-router)# network 10.100.100.2 mask 255.255.255.255

EIGRP di SBY, MKS, BPN:
(config)# router eigrp 65001
(config-router)# network 10.0.0.0
(config-router)# no auto-summary
(config-router)# passive-interface f0/0

BGP SBY:
(config-router)# router bgp 65001
(config-router)# no synchronization
(config-router)# no auto-summary
(config-router)# neighbor 10.100.100.4 remote-as 65001
(config-router)# neighbor 10.100.100.4 update-source loopback 0
(config-router)# neighbor 10.100.100.4 next-hop-self
(config-router)# neighbor 10.100.100.5 remote-as 65001
(config-router)# neighbor 10.100.100.5 update-source loopback 0
(config-router)# neighbor 10.100.100.5 next-hop-self
(config-router)# neighbor 10.0.0.5 remote-as 65002
(config-router)# network 10.0.0.8 mask 255.255.255.252
(config-router)# network 10.0.0.12 mask 255.255.255.252
(config-router)# network 10.1.4.0 mask 255.255.255.0
(config-router)# network 10.100.100.3 mask 255.255.255.255

BGP MKS:
(config-router)# router bgp 65001
(config-router)# no synchronization
(config-router)# no auto-summary
(config-router)# neighbor 10.100.100.3 remote-as 65001
(config-router)# neighbor 10.100.100.3 update-source loopback 0
(config-router)# neighbor 10.100.100.3 next-hop-self
(config-router)# neighbor 10.100.100.5 remote-as 65001
(config-router)# neighbor 10.100.100.5 update-source loopback 0
(config-router)# neighbor 10.100.100.5 next-hop-self
(config-router)# network 10.0.0.12 mask 255.255.255.252
(config-router)# network 10.1.3.0 mask 255.255.255.0
(config-router)# network 10.100.100.4 mask 255.255.255.255

BGP BPN:
(config-router)# router bgp 65001
(config-router)# no synchronization
(config-router)# no auto-summary
(config-router)# neighbor 10.100.100.3 remote-as 65001
(config-router)# neighbor 10.100.100.3 update-source loopback 0
(config-router)# neighbor 10.100.100.3 next-hop-self
(config-router)# neighbor 10.100.100.4 remote-as 65001
(config-router)# neighbor 10.100.100.4 update-source loopback 0
(config-router)# neighbor 10.100.100.4 next-hop-self
(config-router)# network 10.0.0.8 mask 255.255.255.252
(config-router)# network 10.1.5.0 mask 255.255.255.0
(config-router)# network 10.100.100.5 mask 255.255.255.255


# sh ip bgp summary
# sh ip bgp neighbor
# sh ip bgp
# sh ip bgp rib-failure
# sh ip route


0 comments:

Post a Comment